# CVE-2026-15307: Server-side file-write and request forgery via spatial lookups

> Attackers can trigger server-side file writes and network requests via spatial lookups, potentially leading to remote code execution.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** BIT-django-2026-15307, DEBIAN-CVE-2026-15307, ECHO-fda4-bdd4-43f5, GHSA-wvqv-fj8w-qmhm, MINI-26j7-vx32-vh87, MINI-f6wc-7wwf-4cqv, PYSEC-2026-4035, ROOT-APP-PYPI-CVE-2026-15307, UBUNTU-CVE-2026-15307

## What is CVE-2026-15307?

CVE-2026-15307 is a high-severity server-side request forgery vulnerability in Djangoproject Django, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Django 5.2 before 5.2.17 and 6.0 before 6.0.8.
GeoDjango spatial lookups optimistically parse the right-hand-side value as a raster by passing it to the `django.contrib.gis.gdal.GDALRaster` constructor. Any value used in a spatial lookup against a `GeometryField` or `RasterField` reaches this constructor, including untrusted input, for example a spatial-field filter submitted through the Django admin changelist query string by a staff user with view permission. A `dict`, or a `str` holding its JSON representation, is opened in write mode regardless of the constructor's `write=False` default, allowing a file with an attacker-chosen name and contents to be written through a file-backed GDAL driver. Any other `str` is treated as a datasource, allowing an outbound network request through a GDAL virtual filesystem handler. Writing a file to a location later imported by the application can result in remote code execution.
Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected.
Django would like to thank Bence Nagy, localhost-detect, and kimchunbok_ for reporting this issue.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-15307?

6 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | All versions | 5.2.17, 6.0.8 |
| `django` | PyPI | All versions | 5.2.17, 6.0.8 |
| `django` | PyPI | All versions | 5.2.17 |
| `django` | PyPI | From 6.0a1 | 6.0.8 |
| `Django` | PyPI | All versions | 5.2.17 |
| `Django` | PyPI | From 6.0a1 | 6.0.8 |

Products: Djangoproject Django.

## How do I fix CVE-2026-15307?

Upgrade django to a fixed version for your release line: 5.2.17 or 6.0.8.

## Is CVE-2026-15307 being exploited?

There is no known exploitation of CVE-2026-15307 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15307 and fix it if it is affected.

What it is: CVE-2026-15307 is a high-severity server-side request forgery vulnerability in Djangoproject Django, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-15307 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected all versions; fixed in 5.2.17, 6.0.8
- django (PyPI): affected all versions; fixed in 5.2.17, 6.0.8
- django (PyPI): affected all versions; fixed in 5.2.17
- django (PyPI): affected from 6.0a1; fixed in 6.0.8
- Django (PyPI): affected all versions; fixed in 5.2.17
- Django (PyPI): affected from 6.0a1; fixed in 6.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15307/ (Markdown: https://insights.sbomify.com/CVE-2026-15307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15307
- OSV: https://osv.dev/vulnerability/CVE-2026-15307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15307/
Summaries are generated and may contain mistakes; the official description above is the record.
