# CVE-2026-1531: Foreman-kubevirt: foreman_kubevirt: man-in-the-middle due to insecure default ssl verification

> Insecure default SSL verification in Foreman-kubevirt allows Man-in-the-Middle attacks, leading to disclosure or alteration of sensitive information between Satellite and OpenShift.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-2qxw-7fmx-gqfm

## What is CVE-2026-1531?

CVE-2026-1531 is a high-severity vulnerability in Red Hat Satellite 6, published on 2 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in foreman_kubevirt. When configuring the connection to OpenShift, the system disables SSL verification if a Certificate Authority (CA) certificate is not explicitly set. This insecure default allows a remote attacker, capable of intercepting network traffic between Satellite and OpenShift, to perform a Man-in-the-Middle (MITM) attack. Such an attack could lead to the disclosure or alteration of sensitive information.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-1531?

2 open source packages ship an affected version, including foreman_kubevirt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `foreman_kubevirt` | RubyGems | All versions | 0.4.3 |
| `foreman_kubevirt` | RubyGems | All versions | 0.4.3 |

## How do I fix CVE-2026-1531?

Upgrade foreman_kubevirt to 0.4.3 or later.

## Is CVE-2026-1531 being exploited?

There is no known exploitation of CVE-2026-1531 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1531 and fix it if it is affected.

What it is: CVE-2026-1531 is a high-severity vulnerability in Red Hat Satellite 6, published on 2 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1531 in the wild and no public exploit code.

Affected packages and fixed versions:
- foreman_kubevirt (RubyGems): affected all versions; fixed in 0.4.3
- foreman_kubevirt (RubyGems): affected all versions; fixed in 0.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1531/ (Markdown: https://insights.sbomify.com/CVE-2026-1531/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1531
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1531
- OSV: https://osv.dev/vulnerability/CVE-2026-1531

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1531/
Summaries are generated and may contain mistakes; the official description above is the record.
