CVE-2026-15321 MyEMS Admin Backend svg.py on_post cross site scripting

Medium 4.8 Published Updated

Remote attackers can inject malicious scripts via the Admin Backend's svg.py on_post function, potentially compromising user sessions or executing code.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-15321?

CVE-2026-15321 is a medium-severity cross-site scripting vulnerability in MyEMS, published on 10 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in MyEMS up to 6.4.0. The affected element is the function on_post of the file myems-api/core/svg.py of the component Admin Backend. The manipulation of the argument new_values['data'] results in cross site scripting. The attack can be launched remotely. The exploit has been made public and could be used. Upgrading to version 6.5.0 is sufficient to fix this issue. The patch is identified as 4a97edfbd786c779d0322054833b21ddf54d5b06. It is suggested to upgrade the affected component. The issue report remains open even though there is an official fix for it.

Weakness: CWE-94, CWE-79

Which versions are affected by CVE-2026-15321?

How do I fix CVE-2026-15321?

No fix has been published for CVE-2026-15321 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-15321 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15321 exists.

Sources

Also known as GHSA-4qw7-r7cw-fwf5.

Is CVE-2026-15321 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free