# CVE-2026-15321: MyEMS Admin Backend svg.py on_post cross site scripting

> Remote attackers can inject malicious scripts via the Admin Backend's svg.py on_post function, potentially compromising user sessions or executing code.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-4qw7-r7cw-fwf5

## What is CVE-2026-15321?

CVE-2026-15321 is a medium-severity cross-site scripting vulnerability in MyEMS, published on 10 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in MyEMS up to 6.4.0. The affected element is the function on_post of the file myems-api/core/svg.py of the component Admin Backend. The manipulation of the argument new_values['data'] results in cross site scripting. The attack can be launched remotely. The exploit has been made public and could be used. Upgrading to version 6.5.0 is sufficient to fix this issue. The patch is identified as 4a97edfbd786c779d0322054833b21ddf54d5b06. It is suggested to upgrade the affected component. The issue report remains open even though there is an official fix for it.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-15321?


## How do I fix CVE-2026-15321?

No fix has been published for CVE-2026-15321 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-15321 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15321 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15321 and fix it if it is affected.

What it is: CVE-2026-15321 is a medium-severity cross-site scripting vulnerability in MyEMS, published on 10 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15321 exists.

Affected product: MyEMS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15321/ (Markdown: https://insights.sbomify.com/CVE-2026-15321/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15321
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15321
- OSV: https://osv.dev/vulnerability/CVE-2026-15321

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15321/
Summaries are generated and may contain mistakes; the official description above is the record.
