# CVE-2026-15343: Path traversal in Enterprise Server

> Attacker with container access can write arbitrary files, including workflows, leading to code execution and secret exposure in GitHub Enterprise Server.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-h327-qh69-cgch

## What is CVE-2026-15343?

CVE-2026-15343 is a high-severity path traversal vulnerability in GitHub Enterprise Server, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A path traversal vulnerability was identified in GitHub Enterprise Server that allowed an attacker who had code execution inside the Dependabot updater container to write files to arbitrary repository paths, including GitHub Actions workflow files under .github/workflows/ as the path validation did not check the effective path which the attacker could control through the dependency file's directory and symlink target. If the repository used a pull_request_target workflow or had auto-merge enabled, an injected workflow could execute with access to the repository's GitHub Actions secrets. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.21.3, 3.20.5, 3.19.9, 3.18.12, 3.17.18.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-15343?


## How do I fix CVE-2026-15343?

No fix has been published for CVE-2026-15343 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-15343 being exploited?

There is no known exploitation of CVE-2026-15343 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15343 and fix it if it is affected.

What it is: CVE-2026-15343 is a high-severity path traversal vulnerability in GitHub Enterprise Server, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-15343 in the wild and no public exploit code.

Affected product: GitHub Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15343/ (Markdown: https://insights.sbomify.com/CVE-2026-15343/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15343
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15343
- OSV: https://osv.dev/vulnerability/CVE-2026-15343

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15343/
Summaries are generated and may contain mistakes; the official description above is the record.
