CVE-2026-15387 Acceptance of Extraneous Untrusted Data With Trusted Data in GitLab

Medium 4.3 Published Updated

Authenticated developers can inject code into pipeline execution policy jobs via improper dependency handling, requiring an upgrade to GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-15387?

CVE-2026-15387 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 19.1 before 19.1.7, 19.2 before 19.2.5, and 19.3 before 19.3.1 that, under certain conditions, an authenticated user with developer-role permissions could have influenced the execution environment of Pipeline Execution Policy enforcement jobs, due to improper handling of job dependencies.

Weakness: CWE-349

Which versions are affected by CVE-2026-15387?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 19.1.019.1.7, 19.2.5, 19.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-15387?

Upgrade gitlab to a fixed version for your release line: 19.1.7, 19.2.5 or 19.3.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-15387 being exploited?

There is no known exploitation of CVE-2026-15387 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-15387, GHSA-8x29-wc3v-56mg, MINI-49c3-p5pj-m4g5, MINI-8fjr-5hwc-8865, MINI-xcm9-qm3x-f567.

Is CVE-2026-15387 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free