# CVE-2026-15529: yzhao062 pyod persistence.py pyod.utils.persistence.load deserialization


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-997v-r4v7-9f3g, PYSEC-2026-3909

## What is CVE-2026-15529?

CVE-2026-15529 is a medium-severity vulnerability in yzhao062 pyod, published on 13 Jul 2026. 

### Official description

A vulnerability was detected in yzhao062 pyod up to 3.6.1. Affected is the function pyod.utils.persistence.load of the file pyod/utils/persistence.py. Performing a manipulation of the argument path results in deserialization. The attack can be initiated remotely. Upgrading to version 3.6.2 is able to address this issue. It is recommended to apply a patch to fix this issue. The pull request to fix this issue requires some minor changes.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-15529?

3 open source packages ship an affected version, including pyod.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyod` | PyPI | From 3.5.0 | 3.6.2 |
| `pyod` | PyPI | From 3.5.0 | 3.6.2 |
| `pyod` | PyPI | From 3.5.0 | 3.6.2 |

## How do I fix CVE-2026-15529?

Upgrade pyod to 3.6.2 or later.

## Is CVE-2026-15529 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15529 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15529 and fix it if it is affected.

What it is: CVE-2026-15529 is a medium-severity vulnerability in yzhao062 pyod, published on 13 Jul 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15529 exists.

Affected packages and fixed versions:
- pyod (PyPI): affected from 3.5.0; fixed in 3.6.2
- pyod (PyPI): affected from 3.5.0; fixed in 3.6.2
- pyod (PyPI): affected from 3.5.0; fixed in 3.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15529/ (Markdown: https://insights.sbomify.com/CVE-2026-15529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15529
- OSV: https://osv.dev/vulnerability/CVE-2026-15529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15529/
Summaries are generated and may contain mistakes; the official description above is the record.
