# CVE-2026-15571: Auth bypass in Red Hat Data Grid 8

> Attackers can predict account-linking hashes to forge URLs, enabling full account takeover of victims via malicious OIDC clients in Keycloak.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** BIT-keycloak-2026-15571, GHSA-m639-f4cw-m3hm

## What is CVE-2026-15571?

CVE-2026-15571 is a high-severity authentication bypass vulnerability in Red Hat Data Grid 8, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in the legacy client-initiated account-linking endpoint of Keycloak, a widely used open-source identity and access management solution. The mechanism used to protect the account-linking process from unauthorized requests relies on a hash that can be predicted by a malicious OIDC client. By tricking a user into authenticating, an attacker-controlled client can forge a valid linking URL to connect the victim's account to an attacker's external identity. This results in a full account takeover, allowing the attacker to log in as the victim.

Weakness: CWE-341 (Predictable from Observable State)

## Which versions are affected by CVE-2026-15571?

1 open source package ship an affected version, including keycloak.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keycloak` | Bitnami | All versions | 26.7.2 |

## How do I fix CVE-2026-15571?

Upgrade keycloak to 26.7.2 or later.

## Is CVE-2026-15571 being exploited?

There is no known exploitation of CVE-2026-15571 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15571 and fix it if it is affected.

What it is: CVE-2026-15571 is a high-severity authentication bypass vulnerability in Red Hat Data Grid 8, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-15571 in the wild and no public exploit code.

Affected packages and fixed versions:
- keycloak (Bitnami): affected all versions; fixed in 26.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15571/ (Markdown: https://insights.sbomify.com/CVE-2026-15571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15571
- OSV: https://osv.dev/vulnerability/CVE-2026-15571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15571/
Summaries are generated and may contain mistakes; the official description above is the record.
