# CVE-2026-15741: PostgreSQL expression deparse allows SQL injection via EXTRACT argument

> An object owner can execute arbitrary SQL as a superuser via hostile object definitions in PostgreSQL EXTRACT() deparse, affecting tools like pg_dump.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-15741, AZL-95684, BELL-CVE-2026-15741, BIT-postgresql-2026-15741, DEBIAN-CVE-2026-15741, ECHO-3067-e4d3-8356, GHSA-3v2h-jgrj-9jmm, MINI-2qmw-rx86-8cc7, MINI-83pf-5x6h-7c2j, MINI-954q-cwxm-g8x4, MINI-hxxf-jjr8-c3rc, MINI-v38g-8frq-cvp7, MINI-v9x3-wh76-gvg2, ROOT-OS-DEBIAN-11-CVE-2026-15741, UBUNTU-CVE-2026-15741

## What is CVE-2026-15741?

CVE-2026-15741 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SQL injection in PostgreSQL EXTRACT() deparse allows an object owner to execute arbitrary SQL as a superuser via a hostile object definition.  Attacks affect expression deparse consumers broadly, including pg_dump, psql commands like \sf, and any similar usage in non-core tools.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-15741?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-15741?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

## Is CVE-2026-15741 being exploited?

There is no known exploitation of CVE-2026-15741 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15741 and fix it if it is affected.

What it is: CVE-2026-15741 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-15741 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15741/ (Markdown: https://insights.sbomify.com/CVE-2026-15741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15741
- OSV: https://osv.dev/vulnerability/CVE-2026-15741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15741/
Summaries are generated and may contain mistakes; the official description above is the record.
