CVE-2026-15742 PostgreSQL fuzzystrmatch writes effectively-arbitrary addresses, via integer wraparound

High 8.8 Published Updated

Integer overflow in PostgreSQL fuzzystrmatch allows arbitrary code execution via crafted inputs to levenshtein functions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-15742?

CVE-2026-15742 is a high-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Integer wraparound in PostgreSQL fuzzystrmatch allows a user to direct writes to a huge range of addresses, executing arbitrary code as the operating system user running the database, via extreme inputs to SQL function levenshtein() or levenshtein_less_equal(). Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-190

Which versions are affected by CVE-2026-15742?

1 open source package ship an affected version, including postgresql. It affects 1 product.

PackageAffectedFixed in
postgresql BitnamiAll versions14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Products include Postgresql Postgresql.

How do I fix CVE-2026-15742?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

Is CVE-2026-15742 being exploited?

There is no known exploitation of CVE-2026-15742 in the wild and no public exploit code.

All Postgresql Postgresql vulnerabilities

Sources

Also known as ALPINE-CVE-2026-15742, AZL-95747, BELL-CVE-2026-15742, BIT-postgresql-2026-15742, DEBIAN-CVE-2026-15742, ECHO-d44b-2515-54de and 9 more.

Is CVE-2026-15742 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free