CVE-2026-15810 Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover
An attacker can execute arbitrary JavaScript via a malicious URL to take over administrative accounts in self-hosted Looker instances.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-15810?
CVE-2026-15810 is a high-severity cross-site scripting vulnerability in Google Cloud Looker, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL.
Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these.
Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.
Weakness: CWE-79
Which versions are affected by CVE-2026-15810?
How do I fix CVE-2026-15810?
No fix has been published for CVE-2026-15810 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-15810 being exploited?
There is no known exploitation of CVE-2026-15810 in the wild and no public exploit code.
Sources
Also known as GHSA-rvfx-gr5v-9r95.