{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-15810 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-15810 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-15810 is a high-severity cross-site scripting vulnerability in Google Cloud Looker, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-15810 and fix it if it is affected.\n\nWhat it is: CVE-2026-15810 is a high-severity cross-site scripting vulnerability in Google Cloud Looker, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-15810 in the wild and no public exploit code.\n\nAffected product: Google Cloud Looker. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-15810/ (Markdown: https://insights.sbomify.com/CVE-2026-15810/index.md)","id":"CVE-2026-15810","markdown":"https://insights.sbomify.com/CVE-2026-15810/index.md","name":"CVE-2026-15810","record":{"aliases":["GHSA-rvfx-gr5v-9r95"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Google Cloud Looker","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript via a malicious URL to take over administrative accounts in self-hosted Looker instances.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GoogleCloud","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL.\n\nLooker-hosted and Self-hosted were found to be vulnerable.\nThis issue has already been mitigated for Looker-hosted instances. No user action is required for these.\n\nSelf-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover","id":"CVE-2026-15810","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Kronosnet: kronosnet: encryption key exposure in memory after cryptographic configuration changes","id":"CVE-2026-15811"},"packages":[],"prev":{"headline":"Github.com/cri-o/cri-o: fix bypass for cve-2022-4318 — /etc/passwd injection via home env","id":"CVE-2026-15809"},"products":["Looker"],"published":"2026-07-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-24","vendors":["Google Cloud"]},"summary":"An attacker can execute arbitrary JavaScript via a malicious URL to take over administrative accounts in self-hosted Looker instances.","url":"https://insights.sbomify.com/CVE-2026-15810/"}