# CVE-2026-15810: Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover

> An attacker can execute arbitrary JavaScript via a malicious URL to take over administrative accounts in self-hosted Looker instances.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Jul 2026
- **Updated:** 24 Jul 2026
- **Also known as:** GHSA-rvfx-gr5v-9r95

## What is CVE-2026-15810?

CVE-2026-15810 is a high-severity cross-site scripting vulnerability in Google Cloud Looker, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL.

Looker-hosted and Self-hosted were found to be vulnerable.
This issue has already been mitigated for Looker-hosted instances. No user action is required for these.

Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-15810?


## How do I fix CVE-2026-15810?

No fix has been published for CVE-2026-15810 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-15810 being exploited?

There is no known exploitation of CVE-2026-15810 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15810 and fix it if it is affected.

What it is: CVE-2026-15810 is a high-severity cross-site scripting vulnerability in Google Cloud Looker, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-15810 in the wild and no public exploit code.

Affected product: Google Cloud Looker. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15810/ (Markdown: https://insights.sbomify.com/CVE-2026-15810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15810
- OSV: https://osv.dev/vulnerability/CVE-2026-15810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15810/
Summaries are generated and may contain mistakes; the official description above is the record.
