CVE-2026-15830 Potential denial-of-service vulnerability via nested geometry collections
Attackers can cause a denial of service in Django applications by submitting deeply nested geometry collections that trigger unbounded recursion and crashes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-15830?
CVE-2026-15830 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Django 6.0 before 6.0.9 and 5.2 before 5.2.18. GeoDjango's `django.contrib.gis.geos.GEOSGeometry` is subject to a potential denial-of-service when parsing deeply nested `GEOMETRYCOLLECTION` objects supplied as well-known text (WKT), well-known binary (WKB), or hex-encoded WKB, which triggers unbounded recursion and a segmentation fault in the underlying GEOS library. Spatial field lookups and the `django.contrib.gis.forms.GeometryField` form field are also affected. Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected. Django would like to thank Andrew MacPherson and kimchunbok_ for reporting this issue.
Weakness: CWE-674
Which versions are affected by CVE-2026-15830?
8 open source packages ship an affected version, including django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | All versions | 5.2.17, 6.0.8 |
django PyPI | All versions | 5.2.17, 6.0.8 |
django PyPI | All versions | 5.2.17 |
django PyPI | All versions | 5.2.17 |
django PyPI | From 6.0a1 | 6.0.8 |
django PyPI | From 6.0a1 | 6.0.8 |
2 more packages
django PyPI | From 6.1a1 | 6.1.1 |
django PyPI | From 6.1a1 | 6.1.1 |
Products include Djangoproject Django.
How do I fix CVE-2026-15830?
Upgrade django to a fixed version for your release line: 5.2.17, 6.0.8 or 6.1.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-15830 being exploited?
There is no known exploitation of CVE-2026-15830 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2026-15830, DEBIAN-CVE-2026-15830, ECHO-b198-7e8d-0ebb, GHSA-q238-5cxm-5c9h, MINI-8fc2-4r63-6vrj, MINI-xf3r-485w-j35p and 2 more.