# CVE-2026-15830: Potential denial-of-service vulnerability via nested geometry collections

> Attackers can cause a denial of service in Django applications by submitting deeply nested geometry collections that trigger unbounded recursion and crashes.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-django-2026-15830, DEBIAN-CVE-2026-15830, ECHO-b198-7e8d-0ebb, GHSA-q238-5cxm-5c9h, MINI-8fc2-4r63-6vrj, MINI-xf3r-485w-j35p, PYSEC-2026-3717, UBUNTU-CVE-2026-15830

## What is CVE-2026-15830?

CVE-2026-15830 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 6.0 before 6.0.9 and 5.2 before 5.2.18.
GeoDjango's `django.contrib.gis.geos.GEOSGeometry` is subject to a potential denial-of-service when parsing deeply nested `GEOMETRYCOLLECTION` objects supplied as well-known text (WKT), well-known binary (WKB), or hex-encoded WKB, which triggers unbounded recursion and a segmentation fault in the underlying GEOS library. Spatial field lookups and the `django.contrib.gis.forms.GeometryField` form field are also affected.
Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected.
Django would like to thank Andrew MacPherson and kimchunbok_ for reporting this issue.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-15830?

8 open source packages ship an affected version, including django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | All versions | 5.2.17, 6.0.8 |
| `django` | PyPI | All versions | 5.2.17, 6.0.8 |
| `django` | PyPI | All versions | 5.2.17 |
| `django` | PyPI | All versions | 5.2.17 |
| `django` | PyPI | From 6.0a1 | 6.0.8 |
| `django` | PyPI | From 6.0a1 | 6.0.8 |
| `django` | PyPI | From 6.1a1 | 6.1.1 |
| `django` | PyPI | From 6.1a1 | 6.1.1 |

Products: Djangoproject Django.

## How do I fix CVE-2026-15830?

Upgrade django to a fixed version for your release line: 5.2.17, 6.0.8 or 6.1.1.

## Is CVE-2026-15830 being exploited?

There is no known exploitation of CVE-2026-15830 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15830 and fix it if it is affected.

What it is: CVE-2026-15830 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-15830 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected all versions; fixed in 5.2.17, 6.0.8
- django (PyPI): affected all versions; fixed in 5.2.17, 6.0.8
- django (PyPI): affected all versions; fixed in 5.2.17
- django (PyPI): affected all versions; fixed in 5.2.17
- django (PyPI): affected from 6.0a1; fixed in 6.0.8
- django (PyPI): affected from 6.0a1; fixed in 6.0.8
- django (PyPI): affected from 6.1a1; fixed in 6.1.1
- django (PyPI): affected from 6.1a1; fixed in 6.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15830/ (Markdown: https://insights.sbomify.com/CVE-2026-15830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15830
- OSV: https://osv.dev/vulnerability/CVE-2026-15830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15830/
Summaries are generated and may contain mistakes; the official description above is the record.
