{"answers":{"affected":"2 open source packages ship an affected version, including jsii-diff.","exploited":"There is no known exploitation of CVE-2026-15895 in the wild and no public exploit code.","fix":"Upgrade jsii-diff to 1.131.0 or later.","what":"CVE-2026-15895 is a high-severity vulnerability in AWS jsii, published on 15 Jul 2026."},"fix_prompt":"Check this codebase for CVE-2026-15895 and fix it if it is affected.\n\nWhat it is: CVE-2026-15895 is a high-severity vulnerability in AWS jsii, published on 15 Jul 2026. \nExploitation: There is no known exploitation of CVE-2026-15895 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jsii-diff (npm): affected all versions; fixed in 1.131.0\n- jsii-diff (npm): affected all versions; fixed in 1.131.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-15895/ (Markdown: https://insights.sbomify.com/CVE-2026-15895/index.md)","id":"CVE-2026-15895","markdown":"https://insights.sbomify.com/CVE-2026-15895/index.md","name":"CVE-2026-15895","record":{"aliases":["GHSA-wcx4-wpfv-mc5c"],"analysis":null,"analysis_generated_by":null,"assigner":"AMZN","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"OS command injection in the npm package loading component in AWS jsii-diff before 1.131.0 might allow context-dependent attackers to execute arbitrary commands via crafted package specifiers passed to the npm: source argument.\n\nTo mitigate this issue, users should upgrade to jsii-diff v1.131.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OS command injection in jsii-diff in AWS jsii","id":"CVE-2026-15895","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Super Forms \u003c= 6.3.316 - Unauthenticated Path Traversal to Arbitrary File Read via 'sfgtfi' URL Path Parameter","id":"CVE-2026-15896"},"packages":[{"ecosystem":"npm","fixed":["1.131.0"],"introduced":["0"],"last_affected":[],"package":"jsii-diff","purl":null,"source":"GHSA-wcx4-wpfv-mc5c"},{"ecosystem":"npm","fixed":["1.131.0"],"introduced":["0"],"last_affected":[],"package":"jsii-diff","purl":"pkg:npm/jsii-diff","source":"GHSA-wcx4-wpfv-mc5c"}],"prev":{"headline":"Bluetooth Mesh solicitation PDU stack buffer overflow via oversized advertisement","id":"CVE-2026-15894"},"products":["jsii"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["AWS"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-15895/"}