# CVE-2026-15920: Potential cross-site scripting via URLField values in the admin

> Attackers can execute scripts in the Django admin interface if unsafe URLs are stored via non-standard methods, targeting staff users.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 4 Aug 2026
- **Also known as:** BIT-django-2026-15920, DEBIAN-CVE-2026-15920, GHSA-8rmj-xgq5-w9qm, MINI-qhgv-9w28-58gq, UBUNTU-CVE-2026-15920

## What is CVE-2026-15920?

CVE-2026-15920 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Django 5.2 before 5.2.17 and 6.0 before 6.0.8.
`django.contrib.admin.utils.display_for_field()` renders `URLField` values as clickable links in the admin without validating the URL. A value stored with an unsafe scheme is displayed as a link on changelist and read-only admin pages, which allows cross-site scripting against staff users who click the link.
Exploitation requires the unsafe value to already be stored in the database. `URLField` validation through a `ModelForm` or the admin rejects unsafe schemes, so this affects applications that persist `URLField` data without running model validation, for example through direct queryset writes, deserialization, or bulk import of untrusted input.
Django would like to thank Egor Saltykov for reporting this issue.

Weakness: CWE-83 (Improper Neutralization of Script in Attributes in a Web Page)

## Which versions are affected by CVE-2026-15920?

1 open source package ship an affected version, including django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 5.2.0 | 5.2.17, 6.0.8 |

Products: Djangoproject Django.

## How do I fix CVE-2026-15920?

Upgrade django to a fixed version for your release line: 5.2.17 or 6.0.8.

## Is CVE-2026-15920 being exploited?

There is no known exploitation of CVE-2026-15920 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15920 and fix it if it is affected.

What it is: CVE-2026-15920 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-15920 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 5.2.0; fixed in 5.2.17, 6.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15920/ (Markdown: https://insights.sbomify.com/CVE-2026-15920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15920
- OSV: https://osv.dev/vulnerability/CVE-2026-15920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15920/
Summaries are generated and may contain mistakes; the official description above is the record.
