CVE-2026-15925 Improper TLS Hostname Verification in Snowflake Connector for Python
An on-path attacker can bypass TLS hostname verification to intercept credentials and data or execute SQL via the Snowflake Python connector.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-15925?
CVE-2026-15925 is a critical vulnerability in Snowflake Connector for Python, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper TLS hostname verification in Snowflake Connector for Python versions prior to 4.7.1 and 3.18.1 may have allowed a network-positioned attacker to bypass certificate hostname validation on HTTPS connections made by the connector. An attacker with on-path network access could exploit this by intercepting or redirecting network traffic and presenting a certificate signed by any trusted CA for any domain, causing the connector to accept connections without validating that the certificate matched the requested hostname. Successful exploitation requires an on-path traffic interception capability (e.g. ARP/DNS poisoning, rogue access point, BGP hijacking, or malicious proxy/exit node). This vulnerability may have exposed credentials, query data, and staged file contents to interception and tampering, and may have enabled the attacker to issue arbitrary SQL within the context of the victim's connector session. Impact is limited by the privileges of the affected Snowflake role. The fix is available in Snowflake Connector for Python versions 4.7.1 and 3.18.1. Users must manually upgrade.
Weakness: CWE-297
Which versions are affected by CVE-2026-15925?
5 open source packages ship an affected version, including snowflake-connector-python.
| Package | Affected | Fixed in |
|---|---|---|
snowflake-connector-python PyPI | All versions | 3.18.1, 4.7.1 |
snowflake-connector-python PyPI | All versions | 3.18.1 |
snowflake-connector-python PyPI | All versions | 3.18.1 |
snowflake-connector-python PyPI | From 4.0.0 | 4.7.1 |
snowflake-connector-python PyPI | From 4.0.0 | 4.7.1 |
How do I fix CVE-2026-15925?
Upgrade snowflake-connector-python to a fixed version for your release line: 3.18.1 or 4.7.1.
Is CVE-2026-15925 being exploited?
There is no known exploitation of CVE-2026-15925 in the wild and no public exploit code.
Sources
Also known as ECHO-5d7e-7246-3bf5, GHSA-5cc2-282f-jjq2, MINI-3jv6-9prf-r77c, MINI-68wg-3982-cwc2, MINI-9639-6749-3cr8, MINI-jpgj-j4cq-c62x and 1 more.