CVE-2026-15975 Allocation of Resources Without Limits or Throttling in GitLab

High 7.5 Published Updated

An unauthenticated attacker can cause a denial of service in GitLab by exploiting insufficient resource throttling in merge request discussions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-15975?

CVE-2026-15975 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.8 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 that under certain conditions could have allowed an unauthenticated user to cause a denial of service due to insufficient resource throttling when processing merge request discussions.

Weakness: CWE-770

Which versions are affected by CVE-2026-15975?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.8.019.0.5, 19.1.3, 19.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-15975?

Upgrade gitlab to a fixed version for your release line: 19.0.5, 19.1.3 or 19.2.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-15975 being exploited?

There is no known exploitation of CVE-2026-15975 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-15975, GHSA-x55f-grmq-xwwm, MINI-2g2p-j4cf-24vf, MINI-6rvg-xc62-wr5v.

Is CVE-2026-15975 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free