# CVE-2026-16051: WPMU DEV Dashboard < 5.0.1 - Remote Code Execution via Hub Install Action

> An attacker can achieve remote code execution by installing malicious packages via the plugin's unverified remote management interface.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-9hq3-gc69-h95q

## What is CVE-2026-16051?

CVE-2026-16051 is a critical code injection vulnerability in Unknown wpmudev-updates, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The wpmudev-updates WordPress plugin before 5.0.1 does not verify the integrity of the packages installed through its remote management interface, nor protect those requests against replay, allowing an attacker able to obtain or replay a valid signed management request to install and execute arbitrary code (remote code execution).

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-16051?


## How do I fix CVE-2026-16051?

No fix has been published for CVE-2026-16051 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-16051 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-16051 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16051 and fix it if it is affected.

What it is: CVE-2026-16051 is a critical code injection vulnerability in Unknown wpmudev-updates, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-16051 exists.

Affected product: Unknown wpmudev-updates. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16051/ (Markdown: https://insights.sbomify.com/CVE-2026-16051/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16051
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16051
- OSV: https://osv.dev/vulnerability/CVE-2026-16051

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16051/
Summaries are generated and may contain mistakes; the official description above is the record.
