CVE-2026-1606 Improper Control of Generation of Code ('Code Injection') in GitLab

Medium 4.3 Published Updated

An authenticated user can execute arbitrary code via improper input validation in GitLab Snippets, potentially compromising the instance.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1606?

CVE-2026-1606 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 14.8 before 18.11.6, 19.0 before 19.0.3, and 19.1 before 19.1.1 that under certain conditions could have allowed an authenticated user to conceal content within a Snippet due to improper input validation.

Weakness: CWE-94

Which versions are affected by CVE-2026-1606?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.8.018.11.6, 19.0.3, 19.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-1606?

Upgrade gitlab to a fixed version for your release line: 18.11.6, 19.0.3 or 19.1.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-1606 being exploited?

There is no known exploitation of CVE-2026-1606 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1606, GHSA-vxf7-7c9g-m3x8.

Is CVE-2026-1606 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free