# CVE-2026-16117: @fastify/http-proxy vulnerable to prefix escape via URL-encoded characters

> Attackers can bypass prefix rewriting to access hidden upstream paths, including administrative endpoints, by using URL-encoded characters in requests.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-mx7v-qhg9-2mvv

## What is CVE-2026-16117?

CVE-2026-16117 is a critical path traversal vulnerability in @fastify/http-proxy, published on 18 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Impact: @fastify/http-proxy versions up to and including 11.5.0 fail to rewrite the request prefix when the prefix segment is URL-encoded. Fastify's router URL-decodes paths for route matching, but request.url retains the original encoded form, and the prefix-rewrite step uses a literal string replace against the decoded prefix. A request that encodes one or more characters of the configured prefix therefore matches the route but skips the rewrite, so the raw encoded path is forwarded to the upstream unchanged. The upstream then decodes the path and serves it, letting an attacker reach upstream paths that the proxy was configured to hide via rewritePrefix, including internal or administrative endpoints.

Patches: upgrade to @fastify/http-proxy 11.6.0.

Workarounds: none.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-16117?

It affects 1 product.


Products: Fastify Fastify\/Http-Proxy.

## How do I fix CVE-2026-16117?

No fix has been published for CVE-2026-16117 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-16117 being exploited?

There is no known exploitation of CVE-2026-16117 in the wild and no public exploit code.

## Other vulnerabilities in @fastify/http-proxy

- [CVE-2026-33805](https://insights.sbomify.com/CVE-2026-33805/): @fastify/reply-from vulnerable to connection header abuse enabling stripping of proxy-added headers (critical 9.0)
- [CVE-2026-15631](https://insights.sbomify.com/CVE-2026-15631/): @fastify/http-proxy vulnerable to prefix escape via WebSocket path traversal (high 8.7)
- [CVE-2026-85124](https://insights.sbomify.com/CVE-2026-85124/): @fastify/http-proxy vulnerable to prefix escape via backslash dot-segments (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16117 and fix it if it is affected.

What it is: CVE-2026-16117 is a critical path traversal vulnerability in @fastify/http-proxy, published on 18 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-16117 in the wild and no public exploit code.

Affected product: @fastify/http-proxy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16117/ (Markdown: https://insights.sbomify.com/CVE-2026-16117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16117
- OSV: https://osv.dev/vulnerability/CVE-2026-16117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16117/
Summaries are generated and may contain mistakes; the official description above is the record.
