# CVE-2026-1615: jsonpath has Arbitrary Code Injection via Unsafe Evaluation of JSON Path Expressions


- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-87r5-mp6g-5w5j, ROOT-APP-NPM-CVE-2026-1615

## What is CVE-2026-1615?

CVE-2026-1615 is a critical vulnerability in jsonpath, published on 9 Feb 2026. 

### Official description

Versions of the package jsonpath before 1.3.0 are vulnerable to Arbitrary Code Injection via unsafe evaluation of user-supplied JSON Path expressions. The library relies on the static-eval module to process JSON Path input, which is not designed to handle untrusted data safely. An attacker can exploit this vulnerability by supplying a malicious JSON Path expression that, when evaluated, executes arbitrary JavaScript code, leading to Remote Code Execution in Node.js environments or Cross-site Scripting (XSS) in browser contexts. This affects all methods that evaluate JSON Paths against objects, including .query, .nodes, .paths, .value, .parent, and .apply.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-1615?

2 open source packages ship an affected version, including jsonpath.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsonpath` | npm | All versions | 1.3.0 |
| `jsonpath` | npm | All versions | 1.3.0 |

## How do I fix CVE-2026-1615?

Upgrade jsonpath to 1.3.0 or later.

## Is CVE-2026-1615 being exploited?

There is no known exploitation of CVE-2026-1615 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1615 and fix it if it is affected.

What it is: CVE-2026-1615 is a critical vulnerability in jsonpath, published on 9 Feb 2026. 
Exploitation: There is no known exploitation of CVE-2026-1615 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsonpath (npm): affected all versions; fixed in 1.3.0
- jsonpath (npm): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1615/ (Markdown: https://insights.sbomify.com/CVE-2026-1615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1615
- OSV: https://osv.dev/vulnerability/CVE-2026-1615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1615/
Summaries are generated and may contain mistakes; the official description above is the record.
