{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-16158 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-16158 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-16158 is a high-severity vulnerability in @fastify/reply-from, published on 18 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-16158 and fix it if it is affected.\n\nWhat it is: CVE-2026-16158 is a high-severity vulnerability in @fastify/reply-from, published on 18 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-16158 in the wild and no public exploit code.\n\nAffected product: @fastify/reply-from. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-16158/ (Markdown: https://insights.sbomify.com/CVE-2026-16158/index.md)","id":"CVE-2026-16158","markdown":"https://insights.sbomify.com/CVE-2026-16158/index.md","name":"CVE-2026-16158","record":{"aliases":["GHSA-v574-6498-x57v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify reply-from plugin","requires_auth":"none","summary":"An attacker can cause cross-upstream data access and modification due to URL cache key collisions in the Fastify reply-from plugin.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"fastify\\/reply-from","vendor":"fastify"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-441","name":"Unintended Proxy or Intermediary"}],"description":"Impact: @fastify/reply-from versions from 8.3.1 up to but not including 12.6.4 build the internal URL cache key by concatenating the destination and source path without a delimiter. Different destination and source pairs can therefore produce the same key while resolving to different upstream URLs. When getUpstream selects an upstream from request data, a URL cached for one upstream can be reused for a request intended for another upstream, causing cross-upstream data access and modification. The default configuration is affected. Setting disableCache to true prevents the behavior. Patches: upgrade to @fastify/reply-from 12.6.4. Workarounds: pass disableCache: true when registering the plugin.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"@fastify/reply-from vulnerable to cross-upstream request routing via URL cache key collision","id":"CVE-2026-16158","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"IBM DataPower Gateway Out-of-bounds Write","id":"CVE-2026-16159"},"packages":[],"prev":{"headline":"Duplicati backup software v2.3.0.1 is vulnerable to an incorrect permission assignment vulnerability","id":"CVE-2026-16157"},"products":["@fastify/reply-from"],"published":"2026-07-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["@fastify/reply-from"]},"summary":"An attacker can cause cross-upstream data access and modification due to URL cache key collisions in the Fastify reply-from plugin.","url":"https://insights.sbomify.com/CVE-2026-16158/"}