# CVE-2026-16158: @fastify/reply-from vulnerable to cross-upstream request routing via URL cache key collision

> An attacker can cause cross-upstream data access and modification due to URL cache key collisions in the Fastify reply-from plugin.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-v574-6498-x57v

## What is CVE-2026-16158?

CVE-2026-16158 is a high-severity vulnerability in @fastify/reply-from, published on 18 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Impact: @fastify/reply-from versions from 8.3.1 up to but not including 12.6.4 build the internal URL cache key by concatenating the destination and source path without a delimiter. Different destination and source pairs can therefore produce the same key while resolving to different upstream URLs. When getUpstream selects an upstream from request data, a URL cached for one upstream can be reused for a request intended for another upstream, causing cross-upstream data access and modification. The default configuration is affected. Setting disableCache to true prevents the behavior. Patches: upgrade to @fastify/reply-from 12.6.4. Workarounds: pass disableCache: true when registering the plugin.

Weakness: CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2026-16158?

It affects 1 product.


Products: Fastify Fastify\/Reply-From.

## How do I fix CVE-2026-16158?

No fix has been published for CVE-2026-16158 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-16158 being exploited?

There is no known exploitation of CVE-2026-16158 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16158 and fix it if it is affected.

What it is: CVE-2026-16158 is a high-severity vulnerability in @fastify/reply-from, published on 18 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-16158 in the wild and no public exploit code.

Affected product: @fastify/reply-from. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16158/ (Markdown: https://insights.sbomify.com/CVE-2026-16158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16158
- OSV: https://osv.dev/vulnerability/CVE-2026-16158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16158/
Summaries are generated and may contain mistakes; the official description above is the record.
