# CVE-2026-1622: Unredacted data exposure in query.log

> Attackers with local log access can view unredacted sensitive data in query logs due to incomplete obfuscation of error messages.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/AU:N/R:U/V:D/RE:M`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-4j3g-rwwq-4p54, MINI-2hv2-2qhm-vf6p, MINI-62w5-7c8q-wr46, MINI-873j-93vh-fhhr, MINI-8q73-qxjg-jmmv, MINI-925g-vcpm-4f87, MINI-mqrg-jh8j-84v2, MINI-q92x-6x96-7rrf, MINI-r2px-656w-xh73, MINI-rfr2-3943-q952, MINI-x5p5-qc4c-36m7

## What is CVE-2026-1622?

CVE-2026-1622 is a medium-severity vulnerability in neo4j Community Edition, published on 4 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Neo4j Enterprise and Community editions versions prior to 2026.01.3 and 5.26.21 are vulnerable to a potential information disclosure by a user who has ability to access the local log files.

The "obfuscate_literals" option in the query logs does not redact error information, exposing unredacted data in the query log when a customer writes a query that fails. It can allow a user with legitimate access to the local log files to obtain information they are not authorised to see. If this user is also in a position to run queries and trigger errors, this vulnerability can potentially help them to infer information they are not authorised to see through their intended database access.

We recommend upgrading to versions 2026.01.3 (or 5.26.21) where the issue is fixed, and reviewing query log files permissions to ensure restricted access. If your configuration had db.logs.query.obfuscate_literals enabled, and you wish the obfuscation to cover the error messages as well, you need to enable the new configuration setting db.logs.query.obfuscate_errors once you have upgraded Neo4j.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-1622?

4 open source packages ship an affected version, including org.neo4j:neo4j.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.neo4j:neo4j` | Maven | All versions | 5.26.21 |
| `org.neo4j:neo4j` | Maven | All versions | 5.26.21 |
| `org.neo4j:neo4j` | Maven | From 2025.01.0 | 2026.01.3 |
| `org.neo4j:neo4j` | Maven | From 2025.01.0 | 2026.01.3 |

## How do I fix CVE-2026-1622?

Upgrade org.neo4j:neo4j to a fixed version for your release line: 5.26.21 or 2026.01.3.

## Is CVE-2026-1622 being exploited?

There is no known exploitation of CVE-2026-1622 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1622 and fix it if it is affected.

What it is: CVE-2026-1622 is a medium-severity vulnerability in neo4j Community Edition, published on 4 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1622 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.neo4j:neo4j (Maven): affected all versions; fixed in 5.26.21
- org.neo4j:neo4j (Maven): affected all versions; fixed in 5.26.21
- org.neo4j:neo4j (Maven): affected from 2025.01.0; fixed in 2026.01.3
- org.neo4j:neo4j (Maven): affected from 2025.01.0; fixed in 2026.01.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1622/ (Markdown: https://insights.sbomify.com/CVE-2026-1622/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1622
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1622
- OSV: https://osv.dev/vulnerability/CVE-2026-1622

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1622/
Summaries are generated and may contain mistakes; the official description above is the record.
