CVE-2026-16221 fast-uri vulnerable to host confusion via literal backslash authority delimiter

High 7.5 Published Updated

Attackers can bypass host-based security controls in fast-uri by using backslashes, potentially enabling SSRF attacks against internal services or cloud metadata endpoints.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-16221?

CVE-2026-16221 is a high-severity server-side request forgery vulnerability in fast-uri, published on 19 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Impact: fast-uri versions from 2.3.1 through 4.1.0 (including the 3.x line up to 3.1.3 and the 2.x line up to 2.4.2) do not treat a literal backslash character (U+005C) as an authority delimiter. Node's native WHATWG URL parser, used by fetch, undici, and Node's http and https clients, normalizes the backslash to a forward slash for special schemes such as http, https, ws, wss, ftp, and file. As a result, the two parsers extract different hosts from the same input string. Applications that use fast-uri to enforce host-based policy such as allowlists, denylists, loopback or SSRF filtering, redirect validation, or outbound proxy routing before passing the same URL into Node's URL or fetch consumers can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts.

Patches: upgrade to fast-uri 4.1.1, 3.1.4, or 2.4.3.

Workarounds: none.

Weakness: CWE-436

Which versions are affected by CVE-2026-16221?

6 open source packages ship an affected version, including fast-uri. It affects 1 product.

PackageAffectedFixed in
fast-uri npmFrom 2.3.12.4.3
fast-uri npmFrom 2.3.12.4.3
fast-uri npmFrom 3.0.03.1.4
fast-uri npmFrom 3.0.03.1.4
fast-uri npmFrom 4.0.04.1.1
fast-uri npmFrom 4.0.04.1.1

Products include Openjsf Fast-Uri.

How do I fix CVE-2026-16221?

Upgrade fast-uri to a fixed version for your release line: 2.4.3, 3.1.4 or 4.1.1.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-16221 being exploited?

There is no known exploitation of CVE-2026-16221 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-BN07667, CLEANSTART-2026-WA26037, CLSA-2026-1784769538, CLSA-2026-1790893546, CLSA-2026-1791370091, DEBIAN-CVE-2026-16221 and 41 more.

Is CVE-2026-16221 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free