# CVE-2026-16221: fast-uri vulnerable to host confusion via literal backslash authority delimiter

> Attackers can bypass host-based security controls in fast-uri by using backslashes, potentially enabling SSRF attacks against internal services or cloud metadata endpoints.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** CLEANSTART-2026-BN07667, CLEANSTART-2026-WA26037, CLSA-2026-1784769538, CLSA-2026-1790893546, CLSA-2026-1791370091, DEBIAN-CVE-2026-16221, ECHO-ff87-a65e-4352, GHSA-v2hh-gcrm-f6hx, MINI-246w-649x-jv9w, MINI-2f95-q3w5-jg24, MINI-342m-gm5m-23q8, MINI-3rjg-2w9q-72p4, MINI-4956-6h84-gxfg, MINI-4xvj-rxf5-p7wp, MINI-5c87-cp8c-498v, MINI-5gjr-ghv8-f6rm, MINI-5mjm-w5rf-p6vj, MINI-5v9p-jfpc-qx25, MINI-6ww3-56gj-f783, MINI-7cfm-gf8j-fvpg, MINI-7hc2-w3h5-4vx2, MINI-7qm3-9xc7-wjm6, MINI-7v8f-5mvp-5g8j, MINI-829j-c4q9-wr65, MINI-8qqf-2q9m-rpj6, MINI-9fmv-vwcm-8368, MINI-f3v2-28q9-67xf, MINI-f89r-fm82-hcvw, MINI-hh8c-9vwc-pf2m, MINI-jfgf-cc4f-3vg9, MINI-jg8r-3m33-7qjv, MINI-jj7f-r37g-2vqw, MINI-jmw7-j7fw-3w6m, MINI-m78g-grx4-c495, MINI-m7fj-9299-w9x4, MINI-m7hm-g59h-945j, MINI-p794-9294-rgq5, MINI-pmwg-44vg-7q7v, MINI-pr3h-8r8j-h5gf, MINI-q82h-98c9-5jx2, MINI-rcxp-rmf3-xpp3, MINI-rrx6-xgpj-grhj, MINI-vmmr-x9wq-8hx7, MINI-vq95-37gv-jq62, MINI-x2m5-9cvp-rvc6, ROOT-APP-NPM-CVE-2026-16221, UBUNTU-CVE-2026-16221

## What is CVE-2026-16221?

CVE-2026-16221 is a high-severity server-side request forgery vulnerability in fast-uri, published on 19 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Impact: fast-uri versions from 2.3.1 through 4.1.0 (including the 3.x line up to 3.1.3 and the 2.x line up to 2.4.2) do not treat a literal backslash character (U+005C) as an authority delimiter. Node's native WHATWG URL parser, used by fetch, undici, and Node's http and https clients, normalizes the backslash to a forward slash for special schemes such as http, https, ws, wss, ftp, and file. As a result, the two parsers extract different hosts from the same input string. Applications that use fast-uri to enforce host-based policy such as allowlists, denylists, loopback or SSRF filtering, redirect validation, or outbound proxy routing before passing the same URL into Node's URL or fetch consumers can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts. 

Patches: upgrade to fast-uri 4.1.1, 3.1.4, or 2.4.3.

Workarounds: none.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-16221?

6 open source packages ship an affected version, including fast-uri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | From 2.3.1 | 2.4.3 |
| `fast-uri` | npm | From 2.3.1 | 2.4.3 |
| `fast-uri` | npm | From 3.0.0 | 3.1.4 |
| `fast-uri` | npm | From 3.0.0 | 3.1.4 |
| `fast-uri` | npm | From 4.0.0 | 4.1.1 |
| `fast-uri` | npm | From 4.0.0 | 4.1.1 |

Products: Openjsf Fast-Uri.

## How do I fix CVE-2026-16221?

Upgrade fast-uri to a fixed version for your release line: 2.4.3, 3.1.4 or 4.1.1.

## Is CVE-2026-16221 being exploited?

There is no known exploitation of CVE-2026-16221 in the wild and no public exploit code.

## Other vulnerabilities in fast-uri

- [CVE-2026-84292](https://insights.sbomify.com/CVE-2026-84292/): fast-uri vulnerable to authority injection via an unvalidated port in serialize (high 7.5)
- [CVE-2026-84394](https://insights.sbomify.com/CVE-2026-84394/): fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority (high 7.5)
- [CVE-2026-75899](https://insights.sbomify.com/CVE-2026-75899/): fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding (high 7.5)
- [CVE-2026-75931](https://insights.sbomify.com/CVE-2026-75931/): fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references (high 7.5)
- [CVE-2026-75975](https://insights.sbomify.com/CVE-2026-75975/): fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16221 and fix it if it is affected.

What it is: CVE-2026-16221 is a high-severity server-side request forgery vulnerability in fast-uri, published on 19 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-16221 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected from 2.3.1; fixed in 2.4.3
- fast-uri (npm): affected from 2.3.1; fixed in 2.4.3
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.4
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.4
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.1
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16221/ (Markdown: https://insights.sbomify.com/CVE-2026-16221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16221
- OSV: https://osv.dev/vulnerability/CVE-2026-16221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16221/
Summaries are generated and may contain mistakes; the official description above is the record.
