# CVE-2026-16238: PostgreSQL type confusion in pg_restore_attribute_stats() executes arbitrary code

> An object creator can execute arbitrary code as the database OS user via type confusion in pg_restore_attribute_stats.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-16238, BELL-CVE-2026-16238, BIT-postgresql-2026-16238, DEBIAN-CVE-2026-16238, GHSA-6q3v-qqc9-g2rv, MINI-fc59-4jvh-gf9c, UBUNTU-CVE-2026-16238

## What is CVE-2026-16238?

CVE-2026-16238 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Type confusion in PostgreSQL pg_restore_attribute_stats() allows an object creator to execute arbitrary code as the operating system user running the database, via conflation of range and multirange values.  Within major version 18, minor versions before PostgreSQL 18.6 are affected.  Versions before PostgreSQL 18 are unaffected.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2026-16238?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 18.0.0 | 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-16238?

Upgrade postgresql to 18.5.0 or later.

## Is CVE-2026-16238 being exploited?

There is no known exploitation of CVE-2026-16238 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16238 and fix it if it is affected.

What it is: CVE-2026-16238 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-16238 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 18.0.0; fixed in 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16238/ (Markdown: https://insights.sbomify.com/CVE-2026-16238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16238
- OSV: https://osv.dev/vulnerability/CVE-2026-16238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16238/
Summaries are generated and may contain mistakes; the official description above is the record.
