# CVE-2026-16241: PostgreSQL ECPG integer underflow can crash the client

> A malicious database server can crash the PostgreSQL ECPG client by sending malformed data, causing an integer underflow and memory corruption.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-16241, AZL-95711, BELL-CVE-2026-16241, BIT-postgresql-2026-16241, DEBIAN-CVE-2026-16241, ECHO-87ab-7830-3981, GHSA-v76f-gmv6-95jw, MINI-2fvh-g973-8779, MINI-355q-gh6p-vcvg, MINI-62m6-g4qr-738h, MINI-85vh-3v3h-36j7, MINI-8rfp-7j5w-8gcp, MINI-prrm-282x-4869, UBUNTU-CVE-2026-16241

## What is CVE-2026-16241?

CVE-2026-16241 is a low-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Integer underflow in PostgreSQL ECPG allows a database server administrator to achieve temporary denial of service against the ECPG client via sending a bytea value lacking the mandatory prefix.  The client overwrites a huge memory region with bytes outside attacker knowledge or control.  This typically yields a simple SIGSEGV, but rare cases might achieve client-specific integrity impact via the write.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound))

## Which versions are affected by CVE-2026-16241?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-16241?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

## Is CVE-2026-16241 being exploited?

There is no known exploitation of CVE-2026-16241 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16241 and fix it if it is affected.

What it is: CVE-2026-16241 is a low-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-16241 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16241/ (Markdown: https://insights.sbomify.com/CVE-2026-16241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16241
- OSV: https://osv.dev/vulnerability/CVE-2026-16241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16241/
Summaries are generated and may contain mistakes; the official description above is the record.
