CVE-2026-16301 Incorrect Authorization in GitLab

High 8.5 Published Updated

Authenticated developers can bypass authorization checks to execute CI/CD pipelines on protected branches, potentially leading to unauthorized code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-16301?

CVE-2026-16301 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.7 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user with Developer role to execute CI/CD pipelines on protected branches without authorization due to improper authorization checks in the downstream pipeline creation service.

Weakness: CWE-863

Which versions are affected by CVE-2026-16301?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.7.019.2.8, 19.3.5, 19.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-16301?

Upgrade gitlab to a fixed version for your release line: 19.2.8, 19.3.5 or 19.4.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-16301 being exploited?

There is no known exploitation of CVE-2026-16301 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-16301, GHSA-4jhf-7f73-gc68, MINI-23rr-95mj-v5cq, MINI-2rh3-mj4m-vc3v, MINI-2vh9-j84q-3mjw, MINI-33q2-cx37-cfwv and 28 more.

Is CVE-2026-16301 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free