# CVE-2026-16328: consul-mcp-server vulnerable to server side request forgery leading to token exposure

> A malicious client can redirect Consul API traffic to an attacker-controlled endpoint, potentially exposing the server's Consul token.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** BIT-consul-2026-16328, GHSA-5h6c-295f-7pp3

## What is CVE-2026-16328?

CVE-2026-16328 is a high-severity server-side request forgery vulnerability in HashiCorp Tooling, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In consul-mcp-server, versions 0.1.0 up to 0.1.3 did not restrict how the Consul backend address was supplied, allowing a connected client to override the server's configured Consul address via a request header. This may allow a malicious client to redirect the server's Consul API traffic to an attacker-controlled endpoint, potentially exfiltrating the Consul token configured on the server. This vulnerability, CVE-2026-16328, is fixed in consul-mcp-server 0.1.4.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-16328?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 0.1.0 | 0.1.4 |

## How do I fix CVE-2026-16328?

Upgrade consul to 0.1.4 or later.

## Is CVE-2026-16328 being exploited?

There is no known exploitation of CVE-2026-16328 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16328 and fix it if it is affected.

What it is: CVE-2026-16328 is a high-severity server-side request forgery vulnerability in HashiCorp Tooling, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-16328 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 0.1.0; fixed in 0.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16328/ (Markdown: https://insights.sbomify.com/CVE-2026-16328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16328
- OSV: https://osv.dev/vulnerability/CVE-2026-16328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16328/
Summaries are generated and may contain mistakes; the official description above is the record.
