# CVE-2026-16496: terraform-mcp-server vulnerable to cross-user credential inheritance if an MCP session ID is obtained by another user

> Attackers with another user's session ID can execute Terraform commands using that user's credentials in the streamable-HTTP mode.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** BIT-consul-2026-16496, GHSA-4crw-p722-vr7h

## What is CVE-2026-16496?

CVE-2026-16496 is a high-severity authentication bypass vulnerability in HashiCorp Tooling, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The terraform-mcp-server before version 1.1.0 is vulnerable to an authorization bypass in the streamable-HTTP stateful transport mode that may allow a user who obtains another user's MCP session ID to have their tool calls executed using that user's Terraform credentials. This vulnerability, CVE-2026-16496, is fixed in terraform-mcp-server 1.1.0.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2026-16496?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 0.3.0 | 1.1.0 |

## How do I fix CVE-2026-16496?

Upgrade consul to 1.1.0 or later.

## Is CVE-2026-16496 being exploited?

There is no known exploitation of CVE-2026-16496 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16496 and fix it if it is affected.

What it is: CVE-2026-16496 is a high-severity authentication bypass vulnerability in HashiCorp Tooling, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-16496 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 0.3.0; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16496/ (Markdown: https://insights.sbomify.com/CVE-2026-16496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16496
- OSV: https://osv.dev/vulnerability/CVE-2026-16496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16496/
Summaries are generated and may contain mistakes; the official description above is the record.
