CVE-2026-16553 Insufficiently Protected Credentials in GitLab

Medium 5.4 Published Updated

GitLab EE may disclose sensitive information to unintended hosts due to improper handling of upstream requests in virtual registries.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-16553?

CVE-2026-16553 is a medium-severity vulnerability in Gitlab Gitlab, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.8 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 that under certain conditions could have allowed some sensitive information to be disclosed to an unintended host due to improper handling of upstream requests in virtual registries.

Weakness: CWE-522

Which versions are affected by CVE-2026-16553?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.8.019.0.5, 19.1.3, 19.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-16553?

Upgrade gitlab to a fixed version for your release line: 19.0.5, 19.1.3 or 19.2.1.

Is CVE-2026-16553 being exploited?

There is no known exploitation of CVE-2026-16553 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-16553, GHSA-5c98-v836-vg79, MINI-9vfr-73mf-6rpv, MINI-xh5q-q5hg-m28r.

Is CVE-2026-16553 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free