CVE-2026-16584 AWS API MCP Server Security Policy Bypass via Startup Failure
Attackers can bypass security policies to execute denied AWS API operations if server initialization fails, affecting AWS API MCP Server users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-16584?
CVE-2026-16584 is a high-severity vulnerability in aws-api-mcp-server, published on 23 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny or gate. When initialization of the security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect and are unaffected.
To remediate this issue, users should upgrade to version 1.3.47.
Weakness: CWE-455
Which versions are affected by CVE-2026-16584?
3 open source packages ship an affected version, including awslabs-aws-api-mcp-server and awslabs.aws-api-mcp-server.
| Package | Affected | Fixed in |
|---|---|---|
awslabs-aws-api-mcp-server PyPI | From 0.2.13 | 1.3.47 |
awslabs-aws-api-mcp-server PyPI | From 0.2.13 | 1.3.47 |
awslabs.aws-api-mcp-server PyPI | From 0.2.13 | 1.3.47 |
How do I fix CVE-2026-16584?
Upgrade awslabs-aws-api-mcp-server to 1.3.47 or later.
Is CVE-2026-16584 being exploited?
There is no known exploitation of CVE-2026-16584 in the wild and no public exploit code.
Sources
Also known as GHSA-29w2-fq35-v728, PYSEC-2026-3549.