{"answers":{"affected":"3 open source packages ship an affected version, including awslabs-aws-api-mcp-server and awslabs.aws-api-mcp-server.","exploited":"There is no known exploitation of CVE-2026-16584 in the wild and no public exploit code.","fix":"Upgrade awslabs-aws-api-mcp-server to 1.3.47 or later.","what":"CVE-2026-16584 is a high-severity vulnerability in aws-api-mcp-server, published on 23 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-16584 and fix it if it is affected.\n\nWhat it is: CVE-2026-16584 is a high-severity vulnerability in aws-api-mcp-server, published on 23 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-16584 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.13; fixed in 1.3.47\n- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.13; fixed in 1.3.47\n- awslabs.aws-api-mcp-server (PyPI): affected from 0.2.13; fixed in 1.3.47\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-16584/ (Markdown: https://insights.sbomify.com/CVE-2026-16584/index.md)","id":"CVE-2026-16584","markdown":"https://insights.sbomify.com/CVE-2026-16584/index.md","name":"CVE-2026-16584","record":{"aliases":["GHSA-29w2-fq35-v728","PYSEC-2026-3549"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"AWS API MCP Server","requires_auth":"none","summary":"Attackers can bypass security policies to execute denied AWS API operations if server initialization fails, affecting AWS API MCP Server users.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-455","name":"Non-exit on Failed Initialization"}],"description":"Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny or gate. When initialization of the security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect and are unaffected.\n\nTo remediate this issue, users should upgrade to version 1.3.47.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AWS API MCP Server Security Policy Bypass via Startup Failure","id":"CVE-2026-16584","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Path traversal in Better Messages – Chat Rooms, Group Chat, Private Messages \u0026 AI Chat Bots","id":"CVE-2026-16585"},"packages":[{"ecosystem":"PyPI","fixed":["1.3.47"],"introduced":["0.2.13"],"last_affected":[],"package":"awslabs-aws-api-mcp-server","purl":"pkg:pypi/awslabs-aws-api-mcp-server","source":"GHSA-29w2-fq35-v728"},{"ecosystem":"PyPI","fixed":["1.3.47"],"introduced":["0.2.13"],"last_affected":[],"package":"awslabs-aws-api-mcp-server","purl":"pkg:pypi/awslabs-aws-api-mcp-server","source":"PYSEC-2026-3549"},{"ecosystem":"PyPI","fixed":["1.3.47"],"introduced":["0.2.13"],"last_affected":[],"package":"awslabs.aws-api-mcp-server","purl":null,"source":"GHSA-29w2-fq35-v728"}],"prev":{"headline":"Orbit Fox by ThemeIsle \u003c 3.0.8 - Author+ Stored XSS via SVG Upload","id":"CVE-2026-16583"},"products":["aws-api-mcp-server"],"published":"2026-07-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-23","vendors":["AWS"]},"summary":"Attackers can bypass security policies to execute denied AWS API operations if server initialization fails, affecting AWS API MCP Server users.","url":"https://insights.sbomify.com/CVE-2026-16584/"}