# CVE-2026-16584: AWS API MCP Server Security Policy Bypass via Startup Failure

> Attackers can bypass security policies to execute denied AWS API operations if server initialization fails, affecting AWS API MCP Server users.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jul 2026
- **Updated:** 23 Jul 2026
- **Also known as:** GHSA-29w2-fq35-v728, PYSEC-2026-3549

## What is CVE-2026-16584?

CVE-2026-16584 is a high-severity vulnerability in aws-api-mcp-server, published on 23 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny or gate. When initialization of the security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect and are unaffected.

To remediate this issue, users should upgrade to version 1.3.47.

Weakness: CWE-455 (Non-exit on Failed Initialization)

## Which versions are affected by CVE-2026-16584?

3 open source packages ship an affected version, including awslabs-aws-api-mcp-server and awslabs.aws-api-mcp-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `awslabs-aws-api-mcp-server` | PyPI | From 0.2.13 | 1.3.47 |
| `awslabs-aws-api-mcp-server` | PyPI | From 0.2.13 | 1.3.47 |
| `awslabs.aws-api-mcp-server` | PyPI | From 0.2.13 | 1.3.47 |

## How do I fix CVE-2026-16584?

Upgrade awslabs-aws-api-mcp-server to 1.3.47 or later.

## Is CVE-2026-16584 being exploited?

There is no known exploitation of CVE-2026-16584 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16584 and fix it if it is affected.

What it is: CVE-2026-16584 is a high-severity vulnerability in aws-api-mcp-server, published on 23 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-16584 in the wild and no public exploit code.

Affected packages and fixed versions:
- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.13; fixed in 1.3.47
- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.13; fixed in 1.3.47
- awslabs.aws-api-mcp-server (PyPI): affected from 0.2.13; fixed in 1.3.47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16584/ (Markdown: https://insights.sbomify.com/CVE-2026-16584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16584
- OSV: https://osv.dev/vulnerability/CVE-2026-16584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16584/
Summaries are generated and may contain mistakes; the official description above is the record.
