CVE-2026-1659 Allocation of Resources Without Limits or Throttling in GitLab

High 7.5 Published Updated

Unauthenticated attackers can cause denial of service in GitLab by sending specially crafted requests due to insufficient input validation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1659?

CVE-2026-1659 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 9.0 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an unauthenticated user to cause denial of service by sending specially crafted requests due to insufficient input validation.

Weakness: CWE-770

Which versions are affected by CVE-2026-1659?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.0.018.9.7, 18.10.6, 18.11.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-1659?

Upgrade gitlab to a fixed version for your release line: 18.9.7, 18.10.6 or 18.11.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-1659 being exploited?

There is no known exploitation of CVE-2026-1659 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1659, GHSA-vgrr-9p4p-xw4w, UBUNTU-CVE-2026-1659.

Is CVE-2026-1659 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free