{"answers":{"affected":"2 open source packages ship an affected version, including danger.","exploited":"There is no known exploitation of CVE-2026-16629 in the wild and no public exploit code.","fix":"Upgrade danger to 13.0.8 or later.","what":"CVE-2026-16629 is a medium-severity command injection vulnerability in danger-js, published on 22 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-16629 and fix it if it is affected.\n\nWhat it is: CVE-2026-16629 is a medium-severity command injection vulnerability in danger-js, published on 22 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-16629 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- danger (npm): affected all versions; fixed in 13.0.8\n- danger (npm): affected all versions; fixed in 13.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-16629/ (Markdown: https://insights.sbomify.com/CVE-2026-16629/index.md)","id":"CVE-2026-16629","markdown":"https://insights.sbomify.com/CVE-2026-16629/index.md","name":"CVE-2026-16629","record":{"aliases":["GHSA-3x93-p86w-5jvh"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"danger-js CLI","requires_auth":"low_privilege","summary":"Local attackers can execute arbitrary OS commands via the danger.git.diffForFile function in the danger-js CLI.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A vulnerability was identified in danger danger-js up to 13.0.7. Impacted is the function danger.git.diffForFile of the file source/platforms/git/localGetFileAtSHA.ts of the component CLI. Such manipulation of the argument File leads to os command injection. The attack needs to be performed locally. Upgrading to version 13.0.8 is recommended to address this issue. The name of the patch is 087a7290264cc6fb7154ea8c2552a7b2cb8b33a3. It is advisable to upgrade the affected component.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"danger danger-js CLI localGetFileAtSHA.ts danger.git.diffForFile os command injection","id":"CVE-2026-16629","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":8,"next":{"headline":"syncfusion ej2-javascript-ui-controls package.json child_process.exec os command injection","id":"CVE-2026-16630"},"packages":[{"ecosystem":"npm","fixed":["13.0.8"],"introduced":["0"],"last_affected":[],"package":"danger","purl":null,"source":"GHSA-3x93-p86w-5jvh"},{"ecosystem":"npm","fixed":["13.0.8"],"introduced":["0"],"last_affected":[],"package":"danger","purl":"pkg:npm/danger","source":"GHSA-3x93-p86w-5jvh"}],"prev":{"headline":"oclif JIT Plugin Entry child_process.exec os command injection","id":"CVE-2026-16628"},"products":["danger-js"],"published":"2026-07-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-28","vendors":["danger"]},"summary":"Local attackers can execute arbitrary OS commands via the danger.git.diffForFile function in the danger-js CLI.","url":"https://insights.sbomify.com/CVE-2026-16629/"}