CVE-2026-16728 undici vulnerable to downstream response desynchronization via retry interceptor
A malicious upstream can cause response desynchronization in undici's retry interceptor, leading to connection hangs or corrupted data in proxy applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-16728?
CVE-2026-16728 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici's retry interceptor can deliver a response whose body length does not match the Content-Length header exposed to the application after a retry or resume of a partial response. In undici before 6.28.0, from 7.0.0 up to before 7.29.0, and from 8.0.0 up to before 8.9.0, a malicious or faulty upstream can return a partial response with a mismatched framing header, close the socket early, and have the retry interceptor assemble a body of a different length while the original Content-Length stays attached. Applications that use the retry interceptor and forward upstream headers and bodies downstream, such as proxies or gateways, may then emit an invalid HTTP response with a stale Content-Length, leading to downstream response desynchronization, connection hangs, or response corruption. Exploitation requires the retry interceptor enabled, an upstream returning a mismatched partial response, and a downstream forwarder that does not remove or recalculate Content-Length. The issue is fixed in undici 6.28.0, 7.29.0, and 8.9.0.
Weakness: CWE-444
Which versions are affected by CVE-2026-16728?
6 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | All versions | 6.28.0 |
undici npm | All versions | 6.28.0 |
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 8.0.0 | 8.9.0 |
undici npm | From 8.0.0 | 8.9.0 |
Products include Nodejs Undici.
How do I fix CVE-2026-16728?
Upgrade undici to a fixed version for your release line: 6.28.0, 7.29.0 or 8.9.0.
Is CVE-2026-16728 being exploited?
There is no known exploitation of CVE-2026-16728 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-CJ83222, CLEANSTART-2026-HI60053, CLEANSTART-2026-VN19790, DEBIAN-CVE-2026-16728, ECHO-cad4-7176-7840, GHSA-8xcm-r25x-g524 and 26 more.