CVE-2026-16729 undici vulnerable to cookie attribute injection via unsanitized domain and unparsed setCookie fields
Attackers can inject cookie attributes to bypass CSRF protections or override security flags in applications using the undici library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-16729?
CVE-2026-16729 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici's setCookie function does not fully sanitize cookie attributes. In undici before 6.28.0, from 7.0.0 up to before 7.29.0, and from 8.0.0 up to before 8.9.0, a domain value is not checked for semicolons and entries in the unparsed array are not sanitized, so attacker-influenced input can inject additional cookie attributes. For example, a domain value containing a semicolon can append attributes such as SameSite, and an unparsed entry can inject attributes such as HttpOnly, without the caller setting them. Applications that pass user-controlled input to these fields, such as multi-tenant or reverse-proxy servers that scope session cookies to a tenant-supplied domain, can have SameSite CSRF protections bypassed, or the Secure, HttpOnly, and SameSite attributes forced, stripped, or overridden. The issue is fixed in undici 6.28.0, 7.29.0, and 8.9.0.
Weakness: CWE-74
Which versions are affected by CVE-2026-16729?
6 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | All versions | 6.28.0 |
undici npm | All versions | 6.28.0 |
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 8.0.0 | 8.9.0 |
undici npm | From 8.0.0 | 8.9.0 |
Products include Nodejs Undici.
How do I fix CVE-2026-16729?
Upgrade undici to a fixed version for your release line: 6.28.0, 7.29.0 or 8.9.0.
Is CVE-2026-16729 being exploited?
There is no known exploitation of CVE-2026-16729 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as AZL-94443, CLEANSTART-2026-IF82432, CLEANSTART-2026-RE18150, CLEANSTART-2026-US73537, DEBIAN-CVE-2026-16729, ECHO-3d78-4b3b-0a59 and 27 more.