# CVE-2026-16729: undici vulnerable to cookie attribute injection via unsanitized domain and unparsed setCookie fields

> Attackers can inject cookie attributes to bypass CSRF protections or override security flags in applications using the undici library.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** AZL-94443, CLEANSTART-2026-IF82432, CLEANSTART-2026-RE18150, CLEANSTART-2026-US73537, DEBIAN-CVE-2026-16729, ECHO-3d78-4b3b-0a59, GHSA-v3r7-h72x-cjcm, MINI-2c6p-w4vj-xj79, MINI-2g9m-qjw8-wp74, MINI-2r6m-w99v-rqv3, MINI-3h3r-68fg-m67h, MINI-538r-8v25-8m25, MINI-87g3-96gw-6w6w, MINI-9j8w-w73g-xqqw, MINI-9jm3-fm5c-vw96, MINI-9p64-fh6f-x6jc, MINI-c4pp-hf8h-p2fh, MINI-cc73-mqxr-fv6c, MINI-cfv7-4g7c-rcpp, MINI-fqxg-8gx5-whgp, MINI-g4mw-56hq-7vfx, MINI-h2p3-2jmx-m3g4, MINI-h738-c7jc-ww8g, MINI-hm87-m86f-p9m7, MINI-j38m-hj5w-x8j3, MINI-jm7m-p48p-xjvh, MINI-m6h4-ffrw-mxj2, MINI-mxw6-8j28-5v8r, MINI-v68q-hxm5-px57, MINI-ww4v-6656-47w2, MINI-x3vg-hgmq-3gvf, ROOT-APP-NPM-CVE-2026-16729, UBUNTU-CVE-2026-16729

## What is CVE-2026-16729?

CVE-2026-16729 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's setCookie function does not fully sanitize cookie attributes. In undici before 6.28.0, from 7.0.0 up to before 7.29.0, and from 8.0.0 up to before 8.9.0, a domain value is not checked for semicolons and entries in the unparsed array are not sanitized, so attacker-influenced input can inject additional cookie attributes. For example, a domain value containing a semicolon can append attributes such as SameSite, and an unparsed entry can inject attributes such as HttpOnly, without the caller setting them. Applications that pass user-controlled input to these fields, such as multi-tenant or reverse-proxy servers that scope session cookies to a tenant-supplied domain, can have SameSite CSRF protections bypassed, or the Secure, HttpOnly, and SameSite attributes forced, stripped, or overridden. The issue is fixed in undici 6.28.0, 7.29.0, and 8.9.0.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-16729?

6 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | All versions | 6.28.0 |
| `undici` | npm | All versions | 6.28.0 |
| `undici` | npm | From 7.0.0 | 7.29.0 |
| `undici` | npm | From 7.0.0 | 7.29.0 |
| `undici` | npm | From 8.0.0 | 8.9.0 |
| `undici` | npm | From 8.0.0 | 8.9.0 |

Products: Nodejs Undici.

## How do I fix CVE-2026-16729?

Upgrade undici to a fixed version for your release line: 6.28.0, 7.29.0 or 8.9.0.

## Is CVE-2026-16729 being exploited?

There is no known exploitation of CVE-2026-16729 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16729 and fix it if it is affected.

What it is: CVE-2026-16729 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-16729 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected all versions; fixed in 6.28.0
- undici (npm): affected all versions; fixed in 6.28.0
- undici (npm): affected from 7.0.0; fixed in 7.29.0
- undici (npm): affected from 7.0.0; fixed in 7.29.0
- undici (npm): affected from 8.0.0; fixed in 8.9.0
- undici (npm): affected from 8.0.0; fixed in 8.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16729/ (Markdown: https://insights.sbomify.com/CVE-2026-16729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16729
- OSV: https://osv.dev/vulnerability/CVE-2026-16729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16729/
Summaries are generated and may contain mistakes; the official description above is the record.
