# CVE-2026-16796: Improper neutralization of argument delimiters in AWS Bedrock AgentCore Python SDK install_packages()

> Remote authenticated users can execute arbitrary commands in the Code Interpreter sandbox via crafted package names in the AWS Bedrock AgentCore Python SDK.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jul 2026
- **Updated:** 24 Jul 2026
- **Also known as:** GHSA-j6g5-3hh3-pgw8, PYSEC-2026-3551

## What is CVE-2026-16796?

CVE-2026-16796 is a high-severity command injection vulnerability in AWS bedrock-agentcore 1.18.1, published on 23 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Improper neutralization of argument delimiters in the install_packages() method in AWS Bedrock AgentCore Python SDK before 1.18.1 might allow a remote authenticated user to execute arbitrary commands within the Code Interpreter sandbox via crafted package name arguments.

To mitigate this issue, users should upgrade to the patched version 1.18.1.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-16796?

3 open source packages ship an affected version, including bedrock-agentcore.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bedrock-agentcore` | PyPI | All versions | 1.18.1 |
| `bedrock-agentcore` | PyPI | All versions | 1.18.1 |
| `bedrock-agentcore` | PyPI | All versions | 1.18.1 |

## How do I fix CVE-2026-16796?

Upgrade bedrock-agentcore to 1.18.1 or later.

## Is CVE-2026-16796 being exploited?

There is no known exploitation of CVE-2026-16796 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-16796 and fix it if it is affected.

What it is: CVE-2026-16796 is a high-severity command injection vulnerability in AWS bedrock-agentcore 1.18.1, published on 23 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-16796 in the wild and no public exploit code.

Affected packages and fixed versions:
- bedrock-agentcore (PyPI): affected all versions; fixed in 1.18.1
- bedrock-agentcore (PyPI): affected all versions; fixed in 1.18.1
- bedrock-agentcore (PyPI): affected all versions; fixed in 1.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-16796/ (Markdown: https://insights.sbomify.com/CVE-2026-16796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-16796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-16796
- OSV: https://osv.dev/vulnerability/CVE-2026-16796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-16796/
Summaries are generated and may contain mistakes; the official description above is the record.
