# CVE-2026-1703: Limited path traversal when installing wheel archives

> Attackers can extract files outside the installation directory via malicious wheel archives, potentially modifying data in prefix directories.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 2 Feb 2026
- **Also known as:** AZL-76496, AZL-76499, AZL-76593, AZL-76599, AZL-77910, BELL-CVE-2026-1703, CLEANSTART-2026-GK32867, CLEANSTART-2026-JD93552, DEBIAN-CVE-2026-1703, ECHO-7db2-03aa-5591, GHSA-6vgw-5pg2-w6jp, MINI-7hhq-w9p3-cxv4, MINI-7mh7-c68w-24x8, MINI-8ff5-28hr-q3wc, MINI-c44g-5vx9-42rg, MINI-h53f-75xg-m98h, MINI-pc6q-j833-4c2j, MINI-pcx8-f4wp-6938, MINI-phq9-h939-7q2g, MINI-vjfp-68cm-44c2, OESA-2026-1446, PYSEC-2026-1796, RHSA-2026:7610, SUSE-SU-2026:0420-1, SUSE-SU-2026:0805-1, SUSE-SU-2026:20423-1, SUSE-SU-2026:4104-1, UBUNTU-CVE-2026-1703, openSUSE-SU-2026:10210-1, openSUSE-SU-2026:20202-1

## What is CVE-2026-1703?

CVE-2026-1703 is a low-severity path traversal vulnerability in Python Packaging Authority pip, published on 2 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

When pip is installing and extracting a maliciously crafted wheel archive, files may be extracted outside the installation directory. The path traversal is limited to prefixes of the installation directory, thus isn't able to inject or overwrite executable files in typical situations.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-1703?

3 open source packages ship an affected version, including pip.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pip` | PyPI | All versions | 26.0 |
| `pip` | PyPI | All versions | 26.0 |
| `pip` | PyPI | All versions | 26.0 |
| `python-pip` | Red Hat:hummingbird:1 | All versions | 0:26.0.1-2.1.hum1 |
| `python-pip-wheel` | Red Hat:hummingbird:1 | All versions | 0:26.0.1-2.1.hum1 |
| `python-pip` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 22.3.1-150400.17.19.1 |
| `python-pip` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 22.3.1-150400.17.19.1 |
| `python-pip` | SUSE:Linux Enterprise Server 16.0 | All versions | 25.0.1-160000.3.1 |
| `python-pip` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 10.0.1-13.17.1 |
| `python-pip` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 10.0.1-13.23.2 |
| `python-pip` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 25.0.1-160000.3.1 |
| `python-pip` | openSUSE:Leap 15.6 | All versions | 22.3.1-150400.17.19.1 |
| `python-pip` | openSUSE:Leap 16.0 | All versions | 25.0.1-160000.3.1 |
| `python-pip` | openSUSE:Tumbleweed | All versions | 26.0.1-1.1 |

## How do I fix CVE-2026-1703?

Upgrade pip to 26.0 or later.

## Is CVE-2026-1703 being exploited?

There is no known exploitation of CVE-2026-1703 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1703 and fix it if it is affected.

What it is: CVE-2026-1703 is a low-severity path traversal vulnerability in Python Packaging Authority pip, published on 2 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-1703 in the wild and no public exploit code.

Affected packages and fixed versions:
- pip (PyPI): affected all versions; fixed in 26.0
- pip (PyPI): affected all versions; fixed in 26.0
- pip (PyPI): affected all versions; fixed in 26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1703/ (Markdown: https://insights.sbomify.com/CVE-2026-1703/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1703
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1703
- OSV: https://osv.dev/vulnerability/CVE-2026-1703

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1703/
Summaries are generated and may contain mistakes; the official description above is the record.
