{"answers":{"affected":"2 open source packages ship an affected version, including agents.","exploited":"There is no known exploitation of CVE-2026-1721 in the wild and no public exploit code.","fix":"Upgrade agents to 0.3.10 or later.","what":"CVE-2026-1721 is a medium-severity cross-site scripting vulnerability in agents, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-1721 and fix it if it is affected.\n\nWhat it is: CVE-2026-1721 is a medium-severity cross-site scripting vulnerability in agents, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-1721 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- agents (npm): affected all versions; fixed in 0.3.10\n- agents (npm): affected all versions; fixed in 0.3.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-1721/ (Markdown: https://insights.sbomify.com/CVE-2026-1721/index.md)","id":"CVE-2026-1721","markdown":"https://insights.sbomify.com/CVE-2026-1721/index.md","name":"CVE-2026-1721","record":{"aliases":["GHSA-cvhv-6xm6-c3v4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloudflare Agents SDK","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via the OAuth callback error parameter, stealing chat history and accessing connected MCP servers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"cloudflare","cpe":[],"cvss":{"score":6.2,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Summary\n\nA Reflected Cross-Site Scripting (XSS) vulnerability was discovered in the AI Playground's OAuth callback handler. The `error_description` query parameter was directly interpolated into an HTML script tag without proper escaping, allowing attackers to execute arbitrary JavaScript in the context of the victim's session.\n\nRoot cause\n\nThe OAuth callback handler in `site/ai-playground/src/server.ts` directly interpolated the `authError` value, sourced from the `error_description` query parameter,  into an inline `\u003cscript\u003e` tag.\n\nImpact\n\nAn attacker could craft a malicious link that, when clicked by a victim, would:\n\n  *  Steal user chat message history - Access all LLM interactions stored in the user's session.\n\n  *  Access connected MCP Servers - Interact with any MCP servers connected to the victim's session (public or authenticated/private), potentially allowing the attacker to perform actions on the victim's behalf\n\nMitigation:\n\n  *  PR:  https://github.com/cloudflare/agents/pull/841 https://github.com/cloudflare/agents/pull/841 \n\n  *  Agents-sdk users should upgrade to agents@0.3.10\n\n  *  Developers using configureOAuthCallback with custom error handling in their own applications should ensure all user-controlled input is escaped before interpolation.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected Cross-Site Scripting (XSS) vulnerability in AI Playground site","id":"CVE-2026-1721","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"WCFM Marketplace \u003c= 3.7.0 - Insecure Direct Object Reference to Unauthenticated Arbitrary Refund Request Creation","id":"CVE-2026-1722"},"packages":[{"ecosystem":"npm","fixed":["0.3.10"],"introduced":["0"],"last_affected":[],"package":"agents","purl":null,"source":"GHSA-cvhv-6xm6-c3v4"},{"ecosystem":"npm","fixed":["0.3.10"],"introduced":["0"],"last_affected":[],"package":"agents","purl":"pkg:npm/agents","source":"GHSA-cvhv-6xm6-c3v4"}],"prev":{"headline":"Missing authorization in WowOptin: Next-Gen Popup Maker – Create Stunning Popups and Optins for Lead Generation","id":"CVE-2026-1720"},"products":[],"published":"2026-02-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-27","vendors":[]},"summary":"Attackers can execute arbitrary JavaScript via the OAuth callback error parameter, stealing chat history and accessing connected MCP servers.","url":"https://insights.sbomify.com/CVE-2026-1721/"}