CVE-2026-1752 Incorrect Authorization in GitLab

Medium 4.3 Published Updated

Authenticated developers can modify protected environment settings due to improper API authorization checks in GitLab Enterprise Edition.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1752?

CVE-2026-1752 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 8 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 11.3 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an authenticated user with developer-role permissions to modify protected environment settings due to improper authorization checks in the API.

Weakness: CWE-863

Which versions are affected by CVE-2026-1752?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.3.018.8.9, 18.9.5, 18.10.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-1752?

Upgrade gitlab to a fixed version for your release line: 18.8.9, 18.9.5 or 18.10.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-1752 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1752 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1752, GHSA-4gm7-r4jp-2xqg, UBUNTU-CVE-2026-1752.

Is CVE-2026-1752 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free