CVE-2026-17543 SQL injection in ext-pgsql via E'...' backslash breakout
Attackers can execute arbitrary SQL commands via improper backslash escaping in the PHP pgsql extension, potentially reading or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-17543?
CVE-2026-17543 is a high-severity SQL injection vulnerability in Php Php, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper escaping of backslashes in attacker-provided parameters would allow for trivial SQL injection in PHP versions from 8.2.* before 8.2.33, from 8.3.* before 8.3.33, from 8.4.* before 8.4.24, and from 8.5.* before 8.5.9.
Weakness: CWE-89
Which versions are affected by CVE-2026-17543?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 8.2.0 | 8.2.33, 8.3.33, 8.4.24, 8.5.9 |
php Bitnami | From 8.2.0 | 8.2.33, 8.3.33, 8.4.24, 8.5.9 |
php-min Bitnami | From 8.2.0 | 8.2.33, 8.3.33, 8.4.24, 8.5.9 |
Products include Php Php.
How do I fix CVE-2026-17543?
Upgrade libphp to a fixed version for your release line: 8.2.33, 8.3.33, 8.4.24 or 8.5.9.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-17543 being exploited?
There is no known exploitation of CVE-2026-17543 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Php Php
Sources
Also known as AZL-94178, BELL-CVE-2026-17543, BIT-libphp-2026-17543, BIT-php-2026-17543, BIT-php-min-2026-17543, CLSA-2026-1785836282 and 8 more.