# CVE-2026-17543: SQL injection in ext-pgsql via E'...' backslash breakout

> Attackers can execute arbitrary SQL commands via improper backslash escaping in the PHP pgsql extension, potentially reading or modifying database contents.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/AU:Y/R:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** AZL-94178, BELL-CVE-2026-17543, BIT-libphp-2026-17543, BIT-php-2026-17543, BIT-php-min-2026-17543, CLSA-2026-1785836282, CLSA-2026-1785846081, DEBIAN-CVE-2026-17543, ECHO-1147-5a54-625b, MINI-8jvv-253g-fmv7, MINI-8vxj-h938-55c3, MINI-975p-h9cw-234v, MINI-jvp2-j8wx-hq7q, UBUNTU-CVE-2026-17543

## What is CVE-2026-17543?

CVE-2026-17543 is a high-severity SQL injection vulnerability in Php Php, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper escaping of backslashes in attacker-provided parameters would allow for trivial SQL injection in PHP versions from 8.2.* before 8.2.33, from 8.3.* before 8.3.33, from 8.4.* before 8.4.24, and from 8.5.* before 8.5.9.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-17543?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.2.0 | 8.2.33, 8.3.33, 8.4.24, 8.5.9 |
| `php` | Bitnami | From 8.2.0 | 8.2.33, 8.3.33, 8.4.24, 8.5.9 |
| `php-min` | Bitnami | From 8.2.0 | 8.2.33, 8.3.33, 8.4.24, 8.5.9 |

Products: Php Php.

## How do I fix CVE-2026-17543?

Upgrade libphp to a fixed version for your release line: 8.2.33, 8.3.33, 8.4.24 or 8.5.9.

## Is CVE-2026-17543 being exploited?

There is no known exploitation of CVE-2026-17543 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Hunt-Benito/e-is-for-exploit-cve-2026-17543-php-pgsql-sql-injection-backslash-breakout (github_poc): https://github.com/Hunt-Benito/e-is-for-exploit-cve-2026-17543-php-pgsql-sql-injection-backslash-breakout
- Safe PowerShell validator for PHP CVE-2026-17543 exposure via HTTP headers and non-destructive login-form probes. (github_poc): https://github.com/pratham220/CVE-2026-17543-PHP-Exposure-Validator

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-17543 and fix it if it is affected.

What it is: CVE-2026-17543 is a high-severity SQL injection vulnerability in Php Php, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-17543 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.2.0; fixed in 8.2.33, 8.3.33, 8.4.24, 8.5.9
- php (Bitnami): affected from 8.2.0; fixed in 8.2.33, 8.3.33, 8.4.24, 8.5.9
- php-min (Bitnami): affected from 8.2.0; fixed in 8.2.33, 8.3.33, 8.4.24, 8.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-17543/ (Markdown: https://insights.sbomify.com/CVE-2026-17543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-17543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-17543
- OSV: https://osv.dev/vulnerability/CVE-2026-17543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-17543/
Summaries are generated and may contain mistakes; the official description above is the record.
