CVE-2026-17544 Out-of-bounds write in bccomp() via crafted operand and scale
Attackers can trigger out-of-bounds writes in PHP's bccomp function via crafted inputs, potentially leading to code execution or crashes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-17544?
CVE-2026-17544 is a high-severity memory corruption vulnerability in Php Php, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Attacker-provided inputs to bccomp() could lead to an out-of-bounds write with stack and heap corruption in PHP versions from 8.4.* before 8.4.24 and from 8.5.* before 8.5.9.
Weakness: CWE-787
Which versions are affected by CVE-2026-17544?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 8.4.0 | 8.4.24, 8.5.9 |
php Bitnami | From 8.4.0 | 8.4.24, 8.5.9 |
php-min Bitnami | From 8.4.0 | 8.4.24, 8.5.9 |
Products include Php Php.
How do I fix CVE-2026-17544?
Upgrade libphp to a fixed version for your release line: 8.4.24 or 8.5.9.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-17544 being exploited?
There is no known exploitation of CVE-2026-17544 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Php Php
Sources
Also known as BIT-libphp-2026-17544, BIT-php-2026-17544, BIT-php-min-2026-17544, DEBIAN-CVE-2026-17544, MINI-24gv-vmvh-87wj, MINI-59fc-23q6-mvr8 and 1 more.