# CVE-2026-1770: Improper Control of Dynamically-Managed Code Resources in Crafter Studio

> Authenticated developers can bypass Groovy sandbox restrictions to execute arbitrary OS commands, leading to remote code execution.

- **Severity:** Medium 4.5 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:H/VA:H/SC:H/SI:H/SA:H/E:U/AU:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 2 Feb 2026
- **Also known as:** GHSA-gj28-gw7w-3pxc

## What is CVE-2026-1770?

CVE-2026-1770 is a medium-severity code injection vulnerability in CrafterCMS, published on 2 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper Control of Dynamically-Managed Code Resources vulnerability in Crafter Studio of Crafter CMS allows authenticated developers to execute OS commands via Groovy Sandbox Bypass. By inserting malicious Groovy elements, an attacker may bypass sandbox restrictions and obtain RCE (Remote Code Execution).

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2026-1770?

2 open source packages ship an affected version, including org.craftercms:craftercms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.craftercms:craftercms` | Maven | From 4.0.0 | 4.5.0 |
| `org.craftercms:craftercms` | Maven | From 4.0.0 | 4.5.0 |

## How do I fix CVE-2026-1770?

Upgrade org.craftercms:craftercms to 4.5.0 or later.

## Is CVE-2026-1770 being exploited?

There is no known exploitation of CVE-2026-1770 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1770 and fix it if it is affected.

What it is: CVE-2026-1770 is a medium-severity code injection vulnerability in CrafterCMS, published on 2 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1770 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.craftercms:craftercms (Maven): affected from 4.0.0; fixed in 4.5.0
- org.craftercms:craftercms (Maven): affected from 4.0.0; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1770/ (Markdown: https://insights.sbomify.com/CVE-2026-1770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1770
- OSV: https://osv.dev/vulnerability/CVE-2026-1770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1770/
Summaries are generated and may contain mistakes; the official description above is the record.
